<!DOCTYPE html> <html lang="en"> <head prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article#" itemscope itemtype="http://schema.org/Blog"> <meta charset="utf-8" /> <meta http-equiv="X-UA-Compatible" content="IE=edge" /> <style>@-ms-viewport{width:device-width}@-o-viewport{width:device-width}@viewport{width:device-width}</style> <link rel="canonical" href="https://blog.frankel.ch/defense-xml/" itemprop="url"> <title itemprop="name">In defense of XML</title> <meta name="HandheldFriendly" content="true" /> <meta name="viewport" content="width=device-width, initial-scale=1.0" /> <link rel="stylesheet" href="/assets/css/style.css" /> <link rel="stylesheet" href="/assets/css/screen.edited.css" /> <link rel="stylesheet" href="/assets/css/asciidoc.css" /> <link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" /> <link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.1.1/cookieconsent.min.css" /> <meta name="description" content="When I started my career, XML was ubiquitous. The meta-information in a Java JAR file - the manifest - follows a proprietary format. But Java EE designers built it from the ground up on XML: meta-information of all artifacts is in XML format e.g. web.xml, ejb-jar.xml, application.xml, etc. Java EE is one example I experienced personally. But XML was everywhere in the enterprise world at the time. Its prevalence manifested itself in two areas: configuration and data transfer. Ever since then, " /> <link rel="shortcut icon" href="/assets/cup.ico" type="image/x-icon" /> <meta name="referrer" content="no-referrer-when-downgrade" /> <meta property="og:site_name" content="A Java geek" /> <meta property="og:type" content="website" /> <meta property="og:title" content="In defense of XML" /> <meta property="og:description" content="When I started my career, XML was ubiquitous. The meta-information in a Java JAR file - the manifest - follows a proprietary format. But Java EE designers built it from the ground up on XML: meta-information of all artifacts is in XML format e.g. web.xml, ejb-jar.xml, application.xml, etc. Java EE is one example I experienced personally. But XML was everywhere in the enterprise world at the time. Its prevalence manifested itself in two areas: configuration and data transfer. Ever since then, " /> <meta property="og:url" content="https://blog.frankel.ch/defense-xml/" /> <meta property="og:image" content="https://blog.frankel.ch/assets/resources/defense-xml/XML_icon.svg" /> <meta property="og:image:width" content="240" /> <meta property="og:image:height" content="240" /> <meta property="article:published_time" content="2020-09-27T00:00:00+00:00" /> <meta name="twitter:card" content="summary_large_image" /> <meta name="twitter:site:id" content="nicolas_frankel" /> <meta name="twitter:title" content="In defense of XML" /> <meta name="twitter:description" content="When I started my career, XML was ubiquitous. The meta-information in a Java JAR file - the manifest - follows a proprietary format. But Java EE designers built it from the ground up on XML: meta-information of all artifacts is in XML format e.g. web.xml, ejb-jar.xml, application.xml, etc. Java EE is one example I experienced personally. But XML was everywhere in the enterprise world at the time. Its prevalence manifested itself in two areas: configuration and data transfer. Ever since then, " /> <meta name="twitter:url" content="https://blog.frankel.ch/defense-xml/" /> <meta name="twitter:image" content="https://blog.frankel.ch/assets/resources/defense-xml/XML_icon.svg" /> <meta name="twitter:creator:id" content="nicolas_frankel" /> <link rel="alternate" type="application/rss+xml" title="In defense of XML" href="https://blog.frankel.ch/feed.xml" /> </head> <body class="post-template"> <div class="site-wrapper"> <header class="site-header outer"> <div class="inner"> <nav class="site-nav"> <div class="site-nav-left"> <a class="site-nav-logo" href="/">A Java geek</a> <ul class="nav" role="menu"> <li class="nav"> <a class="page-link" href="/me/">Me</a> </li> <li class="nav"> <a class="page-link" href="/books/">Books</a> </li> <li class="nav"> <a class="page-link" href="/speaking/">Speaking</a> </li> <li class="nav"> <a class="page-link" href="/mentions/">Mentions</a> </li> <li class="nav"> <a class="page-link" href="/focus/">Focus</a> </li> </ul> </div> <div class="site-nav-right"> <div class="social-links" itemscope itemtype="http://schema.org/Person" id="main" itemprop="author performer"> <meta itemprop="name" content="Nicolas Fränkel"> <meta itemprop="givenName" content="Nicolas"> <meta itemprop="familyName" content="Fränkel"> <meta itemprop="jobTitle" content="Developer Relationships Manager"> <meta itemprop="worksFor" content="Hazelcast"> <link itemprop="url" href="https://blog.frankel.ch//me"> <link itemprop="image" href="https://blog.frankel.ch/assets/pages/me/me.jpg"> <a class="social-link social-link-tw" href="https://twitter.com/nicolas_frankel" target="_blank" rel="noopener" itemprop="sameAs"> <svg><use xlink:href="/assets/svg/symbols.svg#twitter" href="/assets/svg/symbols.svg#twitter" /></svg> </a> <a class="social-link social-link-tw" href="https://www.linkedin.com/in/nicolasfrankel/" target="_blank" rel="noopener" itemprop="sameAs"> <svg><use xlink:href="/assets/svg/symbols.svg#linkedin" href="/assets/svg/symbols.svg#linkedin" /></svg> </a> <a class="social-link social-link-tw" href="https://github.com/nfrankel" target="_blank" rel="noopener" itemprop="sameAs"> <svg><use xlink:href="/assets/svg/symbols.svg#github" href="/assets/svg/symbols.svg#github" /></svg> </a> <a class="social-link social-link-tw" href="https://blog.frankel.ch/feed.xml" target="_blank" rel="noopener" itemprop="sameAs"> <svg><use xlink:href="/assets/svg/symbols.svg#rss" href="/assets/svg/symbols.svg#rss" /></svg> </a> </div> </div> </nav> </div> </header> <main id="site-main" class="site-main outer"> <div class="inner"> <article class="post-full " itemscope itemtype="http://schema.org/BlogPosting"> <meta itemprop="mainEntityOfPage" content="//defense-xml/" /> <meta itemprop="description" content="" /> <header class="post-full-header"> <section class="post-full-meta"> <time class="post-full-meta-date" datetime="2020-09-27T00:00:00+00:00" itemprop="datePublished dateModified">Sep 27, 2020</time> <span class="date-divider">/</span> <a href='/tag/xml/'>XML</a><span class="tag-divider">,</span> <a href='/tag/json/'>JSON</a><span class="tag-divider">,</span> <a href='/tag/yaml/'>YAML</a><span class="tag-divider">,</span> <a href='/tag/configuration/'>CONFIGURATION</a><span class="tag-divider">,</span> <a href='/tag/data-exchange/'>DATA EXCHANGE</a> </section> <h1 class="post-full-title" itemprop="name headline">In defense of XML</h1> </header> <figure class="post-full-image" style="background-image: url(/assets/resources/defense-xml/XML_icon.svg);background-size: contain" itemscope itemprop="image" itemtype="http://schema.org/ImageObject"> <meta itemprop="url" content="https://blog.frankel.ch/assets/resources/defense-xml/XML_icon.svg"> </figure> <section class="post-full-content"> <div class="kg-card-markdown" itemprop="articleBody"> <div class="paragraph"> <p>When I started my career, XML was ubiquitous. The meta-information in a Java JAR file - the manifest - follows a proprietary format. But Java EE designers built it from the ground up on XML: meta-information of all artifacts is in XML format <em>e.g.</em> <code>web.xml</code>, <code>ejb-jar.xml</code>, <code>application.xml</code>, etc.</p> </div> <div class="paragraph"> <p>Java EE is one example I experienced personally. But XML was everywhere in the enterprise world at the time. Its prevalence manifested itself in two areas: configuration and data transfer.</p> </div> <div class="paragraph"> <p>Ever since then, it would be an euphemism to say XML has been losing in popularity. Other formats, such as JSON and YAML, have replaced it in the hearts of developers. In this post, I&#8217;d like to:</p> </div> <ul><li><span class="primary">Explore some of the reasons why the mighty XML has fallen</span></li><li><span class="primary">Raise some downsides of the popular alternatives</span></li><li><span class="primary">And describe how XML already solved those problems</span></li></ul> <div class="sect1"> <h2 id="the-downfall-of-xml">The downfall of XML</h2> <div class="sectionbody"> <div class="paragraph"> <p>I think there are several reasons that led to the downfall of XML. It&#8217;s not a single one, but the conjunction of them that led to the current state.</p> </div> <div class="sect2"> <h3 id="associated-with-enterprise">Associated with "Enterprise"</h3> <div class="paragraph"> <p>I&#8217;m afraid the worst flaw of XML is its close association with the enterprise world. As everybody knows, Enterprise is notoriously bad - by definition: bloated, heavy, not nimble, etc. And yes, that&#8217;s sarcasm if you wondered.</p> </div> <div class="paragraph"> <p>In general, perception trumps truth. Developers are no different in that regard. In the end, that&#8217;s how Hype-Driven Developers - and most developers, perceive XML nowadays.</p> </div> </div> <div class="sect2"> <h3 id="lack-of-integration-with-front-end">Lack of integration with front-end</h3> <div class="paragraph"> <p>One of the main usages of XML was in the realm <a href="https://en.wikipedia.org/wiki/SOAP" target="_blank" rel="noopener">SOAP web services</a>. Let&#8217;s be frank about it: the ease of consuming those web services from JavaScript and/or the browser is not spectacular.</p> </div> <div class="paragraph"> <p>It' no wonder that JavaScript Object Notation, <em>aka</em> JSON became a <em>de facto</em> standard. JSON brought <a href="https://en.wikipedia.org/wiki/Representational_state_transfer" target="_blank" rel="noopener">REST</a> along with it. As its name implies, JSON is JavaScript native, while XML is not.</p> </div> </div> <div class="sect2"> <h3 id="steep-first-steps">Steep first steps</h3> <div class="paragraph"> <p>JSON is quite easy to start with, YAML even more so. Even with bare XML, one has the concept of namespaces, which are not beginner-friendly. XML allows one document to use elements from different namespaces. On the flip side, it makes designing simple documents more complicated.</p> </div> <div class="paragraph"> <p>XML has a lot of powerful features, but all this power can be confusing to beginners. I willingly admit that they make easy things more complex than they should.</p> </div> </div> <div class="sect2"> <h3 id="performance">Performance</h3> <div class="paragraph"> <p>I&#8217;ve stumbled upon the performance "argument" a couple of time. This is usually "proven" by using a sample describing the same in XML, JSON and YAML. Because of its opening <strong>and</strong> closing tags, the writer shows that XML is quite noisy compared to the other two.</p> </div> <div class="paragraph"> <p>IMHO, this argument is shallow, as all 3 formats are text-based. Thus, you can - and should - compress files. Parsing might be a bit slower, but it depends a lot on the exact parser (and the associated technology stack). In the end, the overhead of transmitting and parsing in XML - if any - is negligible compared to the total time in the whole use-case.</p> </div> <div class="paragraph"> <p>People who favor YAML over JSON use the same reasoning: less characters.</p> </div> </div> <div class="sect2"> <h3 id="abuse">Abuse</h3> <div class="paragraph"> <p>The above reasons are more or less congruent with XML. Yet, I&#8217;m more than willing to admit architects have been abusing XML. I&#8217;ve personally seen SOAP webservices with payload in the order of several megabytes. At that time, you might imagine the performance of such design was not stellar.</p> </div> </div> </div> </div> <div class="sect1"> <h2 id="failings-of-alternatives">Failings of alternatives</h2> <div class="sectionbody"> <div class="paragraph"> <p>JSON, YAML &amp; al. all have their own failings. Here&#8217;s a sample of them:</p> </div> <ul><li><span class="primary">JSON has no comments. The most usual fallback is to use the <code>"_comment"</code> property.</span><div class="listingblock"> <div class="content"> <pre class="rouge highlight"><code data-lang="json"><span class="p">{</span><span class="w">
  </span><span class="nl">"foo"</span><span class="p">:</span><span class="w"> </span><span class="p">{</span><span class="w">
    </span><span class="nl">"_comment"</span><span class="w"> </span><span class="p">:</span><span class="w"> </span><span class="s2">"My important comment"</span><span class="p">,</span><span class="w">
    </span><span class="nl">"bar"</span><span class="p">:</span><span class="w"> </span><span class="kc">true</span><span class="w">
  </span><span class="p">}</span><span class="w">
</span><span class="p">}</span></code></pre> </div> </div></li><li><span class="primary">YAML has no governing body. Individuals manage the specification.</span></li><li><span class="primary">YAML has <strong>22 ways to write booleans</strong> - no less!</span></li></ul> <div class="openblock"> <div class="content"> <div class="quoteblock"> <blockquote> <div class="paragraph"> <p>Anyone who uses YAML long enough will eventually get burned when attempting to abbreviate Norway.</p> </div> </blockquote> <div class="attribution"> &#8212; <a href="https://noyaml.com/" target="_blank" rel="noopener">Nobody wants to write YAML</a> </div> </div> </div> </div> <div class="paragraph"> <p><div class='jekyll-twitter-plugin'><blockquote class="twitter-tweet"><p lang="en" dir="ltr">YAML is to config syntaxes what Python is to programming languages. Seriously, significant whitespaces?<br><br>Have fun with a 500 lines of YAML to configure your Kubernetes deployment, and come back to explain why *you* hate it.</p>&mdash; Nicolas Frankel (@Home for a long time I believe) (@nicolas_frankel) <a href="https://twitter.com/nicolas_frankel/status/1273888063463325697?ref_src=twsrc%5Etfw">June 19, 2020</a></blockquote> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></p> </div> <div class="paragraph"> <p>To cope with the above, other formats have poped-up:</p> </div> <ul><li><span class="primary"><a href="https://github.com/toml-lang/toml" target="_blank" rel="noopener"><abbr title="Tom’s Obvious, Minimal Language">TOML</abbr></a> draws its inspiration from the <a href="https://en.wikipedia.org/wiki/INI_file" target="_blank" rel="noopener"><code>.ini</code></a> format. It allows nested hierarchies of properties</span></li><li><span class="primary">Lightbend pushes the <abbr title="Human-Optimized Config Object Notation">HOCON</abbr> format:</span></li></ul> <div class="openblock"> <div class="content"> <div class="quoteblock"> <blockquote> <div class="paragraph"> <p>This is an informal spec, but hopefully it&#8217;s clear.</p> </div> </blockquote> <div class="attribution"> &#8212; <a href="https://github.com/lightbend/config/blob/master/HOCON.md" target="_blank" rel="noopener">HOCON README</a> </div> </div> <div class="paragraph"> <p>This one statement doesn&#8217;t fill me confidence.</p> </div> </div> </div> </div> </div> <div class="sect1"> <h2 id="the-original-sin-the-lack-of-grammar">The original sin: the lack of grammar</h2> <div class="sectionbody"> <div class="paragraph"> <p>Whatever the format, regardless of their own specific downsides, one of the most important issue is for clients to decide if the read data is <em>correct</em> or not.</p> </div> <div class="paragraph"> <p>When using JSON and YAML, the different clients need to provide <em>ad hoc</em> validation. Issues arise when the provider changes the data format:</p> </div> <ol class="arabic"><li><span class="primary">How to make clients aware that the format changed?</span></li><li><span class="primary">What information to communicate to the client about the format change?</span></li><li><span class="primary">How to keep validation synchronized across clients?</span></li></ol> <div class="paragraph"> <p>XML has this issue solved since the beginning by providing a <strong>grammar</strong>. A grammar plays the same role for a XML document as constraints and types in a SQL database. The most important difference is that you can externalize the grammar.</p> </div> <div class="paragraph"> <p>Several XML grammar implementations are available: <a href="https://www.w3.org/XML/1998/06/xmlspec-report-19980910.htm" target="_blank" rel="noopener">Document Type Definition</a>, <a href="https://www.w3.org/XML/Schema" target="_blank" rel="noopener">XML Schema</a>, <a href="https://relaxng.org/" target="_blank" rel="noopener">Relax NG</a>, etc. The most widespread one is XML Schema. Since a XML Schema is also written in XML format, a web server can host it. Then you can reference it by a publicly-accessible URL.</p> </div> <div class="paragraph"> <p>This approach solves the above issues: when a client receives an XML document, the former looks at the XML Schema URL. It can then fetch it, and check that the data conforms to the schema.</p> </div> <div class="paragraph"> <p>Changing the data format is as simple as versioning the XML Schema file, and publishing it under a new URL.</p> </div> </div> </div> <div class="sect1"> <h2 id="other-benefits-of-xml">Other benefits of XML</h2> <div class="sectionbody"> <div class="paragraph"> <p>In this section, I&#8217;d like to list a couple of benefits of using XML.</p> </div> <div class="dlist"> <dl> <dt class="hdlist1">Public open stewardship</dt> <dd> <p>XML is not under the stewardship of a single person or a company, but of a <abbr title="Non-Governmental Organization">NGO</abbr>, namely the <a href="https://www.w3.org/" target="_blank" rel="noopener">W3C</a>. A W3C specification has a <a href="https://www.w3.org/2019/Process-20190301/" target="_blank" rel="noopener">publicly documented process and defined lifecycle</a>.</p> </dd> <dt class="hdlist1">Battle-proven</dt> <dd> <p>XML is not hype, but benefits from plenty of documentation, blog posts, and <a href="https://stackoverflow.com/questions/tagged/xml" target="_blank" rel="noopener">FAQs</a> available</p> </dd> <dt class="hdlist1">Composable</dt> <dd> <p>While XML doesn&#8217;t strictly enforces namespaces, it&#8217;s considered a good practice. This way, similarly-named entities defined in different namespaces can co-exist in the same document without confusion about semantics.</p> </dd> <dt class="hdlist1">Different flavors</dt> <dd> <p>XML parsing comes into two flavors:</p> <ol class="arabic"><li><span class="primary">Tree-based parsing <em>i.e.</em> <a href="https://dom.spec.whatwg.org/" target="_blank" rel="noopener">Document Object Model</a>. It loads the whole document in memory</span></li><li><span class="primary">Event-based parsing <em>i.e.</em> <a href="http://www.saxproject.org/" target="_blank" rel="noopener">Simple API for XML</a>. It makes possible the parsing of large documents. Note that SAX is <strong>not</strong> a W3C specification.</span></li></ol> </dd> <dt class="hdlist1">Implementation in different languages</dt> <dd> <p>Every commonly-used language in the industry offers at least one XML parsing implementation. This is either baked in the standard library that comes along the language, or available in a third-party one. Here are a couple of them:</p> </dd> </dl> </div> <div class="openblock"> <div class="content"> <table class="tableblock frame-all grid-all fit-content"> <colgroup> <col> <col> <col> <col> <col> </colgroup> <thead> <tr> <th class="tableblock halign-left valign-top">Language</th> <th class="tableblock halign-left valign-top">Implementation</th> <th class="tableblock halign-left valign-top">DOM</th> <th class="tableblock halign-left valign-top">SAX</th> <th class="tableblock halign-left valign-top">Notes</th> </tr> </thead> <tbody> <tr> <th class="tableblock halign-left valign-top" rowspan="2"><p class="tableblock">Java</p></th> <td class="tableblock halign-left valign-top"><p class="tableblock"><a href="https://docs.oracle.com/en/java/javase/14/docs/api/java.xml/org/w3c/dom/package-summary.html">Standard Library</a></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon green"><i class="fa fa-check"></i></span></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon red"><i class="fa fa-times"></i></span></p></td> <td class="tableblock halign-left valign-top"></td> </tr> <tr> <td class="tableblock halign-left valign-top"><p class="tableblock"><a href="https://docs.oracle.com/en/java/javase/14/docs/api/java.xml/org/xml/sax/package-summary.html">Standard Library</a></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon red"><i class="fa fa-times"></i></span></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon green"><i class="fa fa-check"></i></span></p></td> <td class="tableblock halign-left valign-top"></td> </tr> <tr> <th class="tableblock halign-left valign-top"><p class="tableblock">Ruby</p></th> <td class="tableblock halign-left valign-top"><p class="tableblock"><a href="https://nokogiri.org/" target="_blank" rel="noopener">Nokogiri</a></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon green"><i class="fa fa-check"></i></span></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon green"><i class="fa fa-check"></i></span></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock">Wrapper around libxml2</p></td> </tr> <tr> <th class="tableblock halign-left valign-top"><p class="tableblock">Python</p></th> <td class="tableblock halign-left valign-top"><p class="tableblock"><a href="https://docs.python.org/3/library/xml.etree.elementtree.html" target="_blank" rel="noopener">Standard library</a></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon green"><i class="fa fa-check"></i></span></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon green"><i class="fa fa-check"></i></span></p></td> <td class="tableblock halign-left valign-top"></td> </tr> <tr> <th class="tableblock halign-left valign-top" rowspan="2"><p class="tableblock">Go</p></th> <td class="tableblock halign-left valign-top"><p class="tableblock"><a href="https://golang.org/pkg/encoding/xml/" target="_blank" rel="noopener">Standard Library</a></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon green"><i class="fa fa-check"></i></span></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon red"><i class="fa fa-times"></i></span></p></td> <td class="tableblock halign-left valign-top"></td> </tr> <tr> <td class="tableblock halign-left valign-top"><p class="tableblock"><a href="https://github.com/moovweb/gokogiri" target="_blank" rel="noopener">Gogogiri</a></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock">?</p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon green"><i class="fa fa-check"></i></span></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock">Wrapper around libxml2</p></td> </tr> <tr> <th class="tableblock halign-left valign-top"><p class="tableblock">C#</p></th> <td class="tableblock halign-left valign-top"><p class="tableblock"><a href="https://docs.microsoft.com/en-us/dotnet/api/system.xml.xmldocument" target="_blank" rel="noopener">Standard Library</a></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon green"><i class="fa fa-check"></i></span></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon red"><i class="fa fa-times"></i></span></p></td> <td class="tableblock halign-left valign-top"></td> </tr> <tr> <th class="tableblock halign-left valign-top" rowspan="2"><p class="tableblock">C</p></th> <td class="tableblock halign-left valign-top"><p class="tableblock"><a href="http://xmlsoft.org/" target="_blank" rel="noopener">libxml2</a></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon green"><i class="fa fa-check"></i></span></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon green"><i class="fa fa-check"></i></span></p></td> <td class="tableblock halign-left valign-top"></td> </tr> <tr> <td class="tableblock halign-left valign-top"><p class="tableblock"><a href="https://libexpat.github.io/">libexpat</a></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon red"><i class="fa fa-times"></i></span></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon green"><i class="fa fa-check"></i></span></p></td> <td class="tableblock halign-left valign-top"></td> </tr> <tr> <th class="tableblock halign-left valign-top" rowspan="2"><p class="tableblock">C++</p></th> <td class="tableblock halign-left valign-top"><p class="tableblock"><a href="https://pugixml.org/" target="_blank" rel="noopener">pugixml</a></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon green"><i class="fa fa-check"></i></span></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon red"><i class="fa fa-times"></i></span></p></td> <td class="tableblock halign-left valign-top"></td> </tr> <tr> <td class="tableblock halign-left valign-top"><p class="tableblock"><a href="https://xerces.apache.org/xerces-c/" target="_blank" rel="noopener">Xerces</a></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon green"><i class="fa fa-check"></i></span></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon green"><i class="fa fa-check"></i></span></p></td> <td class="tableblock halign-left valign-top"></td> </tr> <tr> <th class="tableblock halign-left valign-top" rowspan="2"><p class="tableblock">Erlang</p></th> <td class="tableblock halign-left valign-top"><p class="tableblock"><a href="http://erlang.org/doc/man/xmerl.html" target="_blank" rel="noopener">Standard library</a></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon green"><i class="fa fa-check"></i></span></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon red"><i class="fa fa-times"></i></span></p></td> <td class="tableblock halign-left valign-top"></td> </tr> <tr> <td class="tableblock halign-left valign-top"><p class="tableblock"><a href="https://github.com/processone/fast_xml/" target="_blank" rel="noopener">Fast XML</a></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon green"><i class="fa fa-check"></i></span></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon green"><i class="fa fa-check"></i></span></p></td> <td class="tableblock halign-left valign-top"></td> </tr> <tr> <th class="tableblock halign-left valign-top" rowspan="2"><p class="tableblock">NodeJS</p></th> <td class="tableblock halign-left valign-top"><p class="tableblock"><a href="https://github.com/libxmljs/libxmljs" target="_blank" rel="noopener">libxmljs</a></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon green"><i class="fa fa-check"></i></span></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon green"><i class="fa fa-check"></i></span></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock">Wrapper around libxml</p></td> </tr> <tr> <td class="tableblock halign-left valign-top"><p class="tableblock"><a href="https://github.com/astro/node-expat" target="_blank" rel="noopener">node-expat</a></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon red"><i class="fa fa-times"></i></span></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock"><span class="icon green"><i class="fa fa-check"></i></span></p></td> <td class="tableblock halign-left valign-top"><p class="tableblock">Wrapper around libexpat</p></td> </tr> </tbody> </table> </div> </div> <div class="dlist"> <dl> <dt class="hdlist1">Document transformation</dt> <dd> <p><abbr title="eXtensible Stylesheet Language Transformation">XSLT</abbr> is <a href="https://www.w3.org/TR/1999/REC-xslt-19991116" target="_blank" rel="noopener">a W3C specification</a>. It allows to transform one XML document into another document in a declarative way. Target documents can be either XML themselves, or not.</p> </dd> <dt class="hdlist1">Document querying</dt> <dd> <p><abbr title="XML Path Language">XPath</abbr> is <a href="https://www.w3.org/TR/2017/REC-xpath-31-20170321/" target="_blank" rel="noopener">another W3C specification</a>. It defines how to query XML documents, similar to CSS selectors.</p> </dd> </dl> </div> </div> </div> <div class="sect1"> <h2 id="conclusion">Conclusion</h2> <div class="sectionbody"> <div class="paragraph"> <p>XML has a lot of advantages compared to other more alternative technologies. In addition to what I described above, it benefits from a <a href="https://www.w3.org/standards/xml/" target="_blank" rel="noopener">rich ecosystem</a>.</p> </div> <div class="paragraph"> <p>It&#8217;s not considered hype by a lot of young (and not so young) developers. I believe would be beneficial if our industry would value more battle-proven technologies than new shiny ones.</p> </div> </div> </div> <div class="sect1 gofurther"> <h2 id="gofurther"> <span class="icon"><i class="fa fa-book"></i></span> <span>To go further:</span> </h2> <div class="sectionbody"> <ul> <li><a href="https://www.json.org/" target="_blank" rel="noopener">Introducing JSON</a></li> <li><a href="https://tools.ietf.org/html/rfc8259" target="_blank" rel="noopener">The JavaScript Object Notation (JSON) Data Interchange Format</a></li> <li><a href="https://yaml.org/" target="_blank" rel="noopener">YAML Ain't Markup Language</a></li> <li><a href="https://yaml.org/spec/1.2/spec.html" target="_blank" rel="noopener">YAML Ain’t Markup Language (YAML™) v1.2</a></li> <li><a href="https://noyaml.com/" target="_blank" rel="noopener">Nobody wants to write YAML</a></li> <li><a href="https://github.com/toml-lang/toml" target="_blank" rel="noopener">Tom’s Obvious, Minimal Language</a></li> <li><a href="https://www.w3.org/TR/xml/" target="_blank" rel="noopener">eXtensible Markup Language (W3C recommandation)</a></li> </ul> </div> </div> <div style="text-align:center"> <a href="https://twitter.com/nicolas_frankel" class="twitter-follow-button" data-size="large" data-show-count="false">Follow @nicolas_frankel</a> </div> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div> </section> <footer class="post-full-footer"> <section class="author-card"> <img class="author-profile-image" src="/assets/pages/me/me.jpg" alt="Nicolas Fränkel" /> <section class="author-card-content"> <h4 class="author-card-name" itemprop="author publisher" itemscope itemid="main" itemtype="http://schema.org/Person"> <a href="/me" itemprop="name">Nicolas Fränkel</a> </h4> <p>Developer Advocate with 15+ years experience consulting for many different customers, in a wide range of contexts (such as telecoms, banking, insurances, large retail and public sector). Usually working on Java/Java EE and Spring technologies, but with focused interests like Rich Internet Applications, Testing, CI/CD and DevOps. Currently working for Hazelcast. Also double as a teacher in universities and higher education schools, a trainer and triples as a book author.</p> </section> </section> <div class="post-full-footer-right"> <a class="author-card-button" href="/me">Read More</a> </div> </footer> <section class="post-full-comments"> <div id="disqus_thread"></div> <script>var disqus_config=function(){this.page.url="https://blog.frankel.ch/defense-xml/",this.page.identifier="In defense of XML"};!function(){var e=document,t=e.createElement("script");t.src="https://blog-frankel.disqus.com/embed.js",t.setAttribute("data-timestamp",+new Date),(e.head||e.body).appendChild(t)}();</script> </section> </article> </div> </main> <aside class="read-next outer"> <div class="inner"> <div class="read-next-feed"> <article class="read-next-card" style="background-image: url(/assets/resources/defense-xml/XML_icon.svg)"> <header class="read-next-card-header"> <small class="read-next-card-header-sitetitle">&mdash; A Java geek &mdash;</small> <h3 class="read-next-card-header-title"><a href="/tag/xml/">Xml</a></h3> </header> <div class="read-next-divider"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><path d="M13 14.5s2 3 5 3 5.5-2.463 5.5-5.5S21 6.5 18 6.5c-5 0-7 11-12 11C2.962 17.5.5 15.037.5 12S3 6.5 6 6.5s4.5 3.5 4.5 3.5" /></svg> </div> <div class="read-next-card-content"> <ul> <li><a href="https://blog.frankel.ch/use-local-resources-when-validating-xml/">Use local resources when validating XML</a></li> <li><a href="https://blog.frankel.ch/xml-validation-with-importedincluded-schemas/">XML validation with imported/included schemas</a></li> <li><a href="https://blog.frankel.ch/discover-spring-authoring/">Discover Spring authoring</a></li> </ul> </div> <footer class="read-next-card-footer"> <a href="/tag/xml/"> See all 4 posts → </a> </footer> </article> <article class="post-card post-template"> <a class="post-card-image-link" href="/customizing-github-profile/2/"> <div class="post-card-image" style="background-image: url(/assets/resources/customizing-github-profile/Octocat_medium.jpg);background-size: contain"></div> </a> <div class="post-card-content"> <a class="post-card-content-link" href="/customizing-github-profile/2/"> <header class="post-card-header"> <time class="post-card-meta-date" datetime="2020-09-20T00:00:00+00:00">Sep 20, 2020</time> <span class="post-card-tags">Continuous Integration</span> <span class="post-card-tags">GitHub Action</span> <h2 class="post-card-title">Customizing your GitHub profile - Building</h2> </header> <section class="post-card-excerpt"> <p>In the previous post, we had a look on how to write a Kotlin script to automatically write a README that dynamically aggregates various data sources. In this follow-up post, we will describe how to run this script through the use of GitHub Actions. Yet another Continuous Integration tool It has been some time since Hudson, now known as Jenkins, was the leading (only?) Continuous Integration server available on the market. The last years has seen an precambrian explosion of alternatives: Atlas</p> </section> </a> <footer class="post-card-meta"> <img class="author-profile-image" src="/assets/pages/me/me_small.jpg" alt="" /> <span class="post-card-author"> <a href="/me/" itemprop="name">Nicolas Fränkel</a> </span> </footer> </div> </article> </div> </div> </aside> <div class="floating-header"> <div class="floating-header-logo"> <a href="/"> <span>A Java geek</span> </a> </div> <span class="floating-header-divider">&mdash;</span> <div class="floating-header-title">In defense of XML</div> <div class="floating-header-share"> <div class="floating-header-share-label">Share this <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"> <path d="M7.5 15.5V4a1.5 1.5 0 1 1 3 0v4.5h2a1 1 0 0 1 1 1h2a1 1 0 0 1 1 1H18a1.5 1.5 0 0 1 1.5 1.5v3.099c0 .929-.13 1.854-.385 2.748L17.5 23.5h-9c-1.5-2-5.417-8.673-5.417-8.673a1.2 1.2 0 0 1 1.76-1.605L7.5 15.5zm6-6v2m-3-3.5v3.5m6-1v2" /> </svg> </div> <a class="floating-header-share-fb" href="https://www.facebook.com/sharer.php?p[url]=https://blog.frankel.ch/defense-xml/&p[title]=In defense of XML&p[summary]=When I started my career, XML was ubiquitous. The meta-information in a Java JAR file - the manifest - follows a proprietary format. But Java EE designers built it from the ground up on XML: meta-information of all artifacts is in XML format e.g. web.xm..." onclick="window.open(this.href, 'share-facebook','width=580,height=296');return false;"> <svg><use xlink:href="/assets/svg/symbols.svg#facebook" href="/assets/svg/symbols.svg#facebook" /></svg> </a> <a class="floating-header-share-tw" href="https://twitter.com/intent/tweet?text=In defense of XML&url=https://blog.frankel.ch/defense-xml/&hashtags=xml,json,yaml,configuration,data exchange,"> <svg><use xlink:href="/assets/svg/symbols.svg#twitter" href="/assets/svg/symbols.svg#twitter" /></svg> </a> <a class="floating-header-share-li" href="https://www.linkedin.com/shareArticle?mini=true&url=https://blog.frankel.ch/defense-xml/&title=In defense of XML&summary=When I started my career, XML was ubiquitous. The meta-information in a Java JAR file - the manifest - follows a proprietary format. But Java EE designers built it from the ground up on XML: meta-information of all artifacts is in XML format e.g. web.xm...&source=https://blog.frankel.ch" onclick="window.open(this.href, 'share-linkedin','width=580,height=296');return false;"> <svg><use xlink:href="/assets/svg/symbols.svg#linkedin" href="/assets/svg/symbols.svg#linkedin" /></svg> </a> <a class="floating-header-share-rd" href="https://www.reddit.com/submit?url=https://blog.frankel.ch/defense-xml/&title=In defense of XML" onclick="window.open(this.href, 'share-reddit','width=900,height=750');return false;"> <svg><use xlink:href="/assets/svg/symbols.svg#reddit" href="/assets/svg/symbols.svg#reddit" /></svg> </a> </div> <progress class="progress" value="0"> <div class="progress-container"> <span class="progress-bar"></span> </div> </progress> </div> <footer class="site-footer outer"> <div class="site-footer-content inner"> <section class="copyright"><a href="https://blog.frankel.ch/">A Java geek</a> &copy; 2008-2020</section> <section class="poweredby">v. 1bdc568a8e323ed63f1101179b7e5c99c6896fd0/760035205</section> <nav class="site-footer-nav"> <a href="/">Latest Posts</a> </nav> </div> </footer> </div> <script>var google_analytics="UA-8347748-1";</script> <script src="/assets/js/ga.js"></script> <script>document.addEventListener("DOMContentLoaded",function(){function e(){l=window.scrollY,n()}function t(){u=window.innerHeight,m=Math.max(document.body.scrollHeight,document.body.offsetHeight,document.documentElement.clientHeight,document.documentElement.scrollHeight,document.documentElement.offsetHeight),n()}function n(){s||requestAnimationFrame(o),s=!0}function o(){var e=d.getBoundingClientRect().top+window.scrollY,t=d.offsetHeight+35,n=m-u;l>=e+t?c.classList.add("floating-active"):c.classList.remove("floating-active"),i.setAttribute("max",n),i.setAttribute("value",l),s=!1}var i=document.querySelector("progress"),c=document.querySelector(".floating-header"),d=document.querySelector(".post-full-title"),l=window.scrollY,u=window.innerHeight,m=Math.max(document.body.scrollHeight,document.body.offsetHeight,document.documentElement.clientHeight,document.documentElement.scrollHeight,document.documentElement.offsetHeight),s=!1;window.addEventListener("scroll",e,{passive:!0}),window.addEventListener("resize",t,!1),o()});</script> <script defer src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.1.1/cookieconsent.min.js"></script> <script defer src="/assets/js/cookieconsent.js"></script> </body> </html>